Grid Create(Document, Arc) Method |
Creates a new radial grid line.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- document Document
- The document in which the new instance is created.
- arc Arc
- An arc object that represents the location of the new grid curve.
Return Value
GridThe newly created grid.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- The input arc is not on a horizontal plane. |
ArgumentNullException | A non-optional argument was null |

The arc should be on a horizontal plane.