Advanced |
This class encapsulates advanced lighting loss factor calculation.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The AdvancedLossFactor type exposes the following members.

Name | Description | |
---|---|---|
![]() | AdvancedLossFactor | Creates an advanced loss factor object with values set to no loss. |
![]() | AdvancedLossFactor(AdvancedLossFactor) | Creates a copy of the given advanced loss factor object |
![]() | AdvancedLossFactor(Double, Double, Double, Double, Double, Double, Double) | Creates an advanced loss factor object with the given values. |

Name | Description | |
---|---|---|
![]() | BallastLossFactor | The ballast loss factor. |
![]() | LampLumenDepreciation | The lamp lumen depreciation loss factor. |
![]() | LampTiltLossFactor | The lamp tilt loss factor. |
![]() | LuminaireDirtDepreciation | The luminaire dirt depreciation loss factor. |
![]() | SurfaceDepreciationLossFactor | The surface depreciation loss factor. |
![]() | TemperatureLossFactor | The temperature loss factor. |
![]() | VoltageLossFactor | The voltage loss factor. |

Name | Description | |
---|---|---|

Advanced lighting loss factor is a combination of several different factors. Each factor has a value of 0.0 (total loss) to 1.0 (no loss).