Advanced |
This class encapsulates advanced lighting loss factor calculation.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The AdvancedLossFactor type exposes the following members.

Name | Description | |
---|---|---|
![]() | AdvancedLossFactor | Creates an advanced loss factor object with values set to no loss. |
![]() | AdvancedLossFactor(AdvancedLossFactor) | Creates a copy of the given advanced loss factor object |
![]() | AdvancedLossFactor(Double, Double, Double, Double, Double, Double, Double) | Creates an advanced loss factor object with the given values. |

Name | Description | |
---|---|---|
![]() | BallastLossFactor | The ballast loss factor. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from LossFactor ) |
![]() | LampLumenDepreciation | The lamp lumen depreciation loss factor. |
![]() | LampTiltLossFactor | The lamp tilt loss factor. |
![]() | LossFactorValue | The calculated loss factor value (Inherited from LossFactor ) |
![]() | LuminaireDirtDepreciation | The luminaire dirt depreciation loss factor. |
![]() | SurfaceDepreciationLossFactor | The surface depreciation loss factor. |
![]() | TemperatureLossFactor | The temperature loss factor. |
![]() | VoltageLossFactor | The voltage loss factor. |

Name | Description | |
---|---|---|
![]() | Clone | Creates a copy of the LossFactor derived object. (Inherited from LossFactor ) |
![]() | Dispose | (Inherited from LossFactor ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Advanced lighting loss factor is a combination of several different factors. Each factor has a value of 0.0 (total loss) to 1.0 (no loss).