AdvancedLossFactor Class


Advanced Loss Factor Class

This class encapsulates advanced lighting loss factor calculation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting LossFactor
Autodesk.Revit.DB.Lighting AdvancedLossFactor

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AdvancedLossFactor : LossFactor

The AdvancedLossFactor type exposes the following members.

Constructors
Name Description
Public method AdvancedLossFactor Creates an advanced loss factor object with values set to no loss.
Public method AdvancedLossFactor(AdvancedLossFactor) Creates a copy of the given advanced loss factor object
Public method AdvancedLossFactor(Double, Double, Double, Double, Double, Double, Double) Creates an advanced loss factor object with the given values.
Top
Properties
Name Description
Public property BallastLossFactor The ballast loss factor.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from LossFactor )
Public property LampLumenDepreciation The lamp lumen depreciation loss factor.
Public property LampTiltLossFactor The lamp tilt loss factor.
Public property LossFactorValue The calculated loss factor value
(Inherited from LossFactor )
Public property LuminaireDirtDepreciation The luminaire dirt depreciation loss factor.
Public property SurfaceDepreciationLossFactor The surface depreciation loss factor.
Public property TemperatureLossFactor The temperature loss factor.
Public property VoltageLossFactor The voltage loss factor.
Top
Methods
Name Description
Public method Clone Creates a copy of the LossFactor derived object.
(Inherited from LossFactor )
Public method Dispose
(Inherited from LossFactor )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Advanced lighting loss factor is a combination of several different factors. Each factor has a value of 0.0 (total loss) to 1.0 (no loss).
See Also