Post |
Post pattern class.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PostPattern type exposes the following members.

Name | Description | |
---|---|---|
![]() | CornerPost | Accesses the object containing properties related to the corner post. |
![]() | CornerPostAngle | The angle between neighboring railing segments which conditions inserting post along a railing path. |
![]() | CornerPostCondition | The condition which controls the insertion of corner posts. |
![]() | EndPost | Accesses the object containing properties related to the end post. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | StartPost | Accesses the object containing properties related to the start post. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the PostPattern |