PostPattern Class


Post Pattern Class

Post pattern class.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Architecture PostPattern

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PostPattern : IDisposable

The PostPattern type exposes the following members.

Properties
Name Description
Public property CornerPost Accesses the object containing properties related to the corner post.
Public property CornerPostAngle The angle between neighboring railing segments which conditions inserting post along a railing path.
Public property CornerPostCondition The condition which controls the insertion of corner posts.
Public property EndPost Accesses the object containing properties related to the end post.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property StartPost Accesses the object containing properties related to the start post.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the PostPattern
Top
See Also