ControlledApplication Class


Controlled Application Class

Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.
Inheritance Hierarchy
System Object
Autodesk.Revit.ApplicationServices ControlledApplication

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ControlledApplication

The ControlledApplication type exposes the following members.

Properties
Name Description
Public property ActiveAddInId
Public property AllUsersAddinsLocation Add-ins location for all users.
Public property Cities
Public property Create
Public property CurrentUserAddinsLocation Add-ins location for current user.
Public property CurrentUsersAddinsDataFolderPath Path to AddinsData folder for the current user.
Public property CurrentUsersDataFolderPath Path to data folder for the current user.
Public property IsLateAddinLoading Indicates whether this add-in is loaded on the fly or not. If it is loaded when is Revit starting up, it is false, otherwise it should be true.
Public property Language
Public property Product
Public property RecordingJournalFilename Retrieve the name of the journal file that Revit is currently recording to.
Public property SharedParametersFilename
Public property SubVersionNumber The minor version number of Revit.
Public property VersionBuild
Public property VersionName
Public property VersionNumber
Top
Methods
Name Description
Public method Static member GetFailureDefinitionRegistry Returns the instance of FailureDefinitionRegistry.
Public method GetLibraryPaths Returns path information identifying where Revit searches for content.
Public method IsJournalPlaying Determines if the application is currently in journal playback mode.
Public method OpenSharedParameterFile
Public method Static member RegisterFailuresProcessor Registers Revit application-wide instance of Failures Processor.
Public method SetLibraryPaths
Public method WriteJournalComment Writes a comment to the Revit journal file
Top
Events
Name Description
Public event ApplicationInitialized Subscribe to this event to get notified after the Revit application has been initialized.
Public event DocumentChanged Subscribe to the FailuresProcessingEvent event to be notified when Revit document has changed.
Public event DocumentClosed Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event DocumentClosing Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event DocumentCreated Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event DocumentCreating Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
Public event DocumentOpened Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event DocumentOpening Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
Public event DocumentPrinted Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event DocumentPrinting Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event DocumentReloadedLatest Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.
Public event DocumentReloadingLatest Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.
Public event DocumentSaved Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event DocumentSavedAs Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event DocumentSaving Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event DocumentSavingAs Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

Public event DocumentSynchronizedWithCentral Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event DocumentSynchronizingWithCentral Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event ElementTypeDuplicated Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.
Public event ElementTypeDuplicating Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type.
Public event FailuresProcessing Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event FamilyLoadedIntoDocument Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.
Public event FamilyLoadingIntoDocument Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document.
Public event FileExported Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event FileExporting Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event FileImported Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event FileImporting Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event LinkedResourceOpened Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.
Public event LinkedResourceOpening Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.
Public event ProgressChanged Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
Public event ViewPrinted Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event ViewPrinting Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.
Public event WorksharedOperationProgressChanged # Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.
Top
See Also