Controlled |
Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ControlledApplication type exposes the following members.

Name | Description | |
---|---|---|
![]() | ActiveAddInId | Retrieves the Id of the currently running external application. |
![]() | AllUsersAddinsLocation | The folder location for .addin files for all users. |
![]() ![]() | Cities | Returns a set of all the known city locations within Revit. |
![]() | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects. |
![]() | CurrentUserAddinsLocation | The folder location for .addin files for the current user. |
![]() | CurrentUsersAddinsDataFolderPath | Path to AddinsData folder for the current user. |
![]() | CurrentUsersDataFolderPath | Path to data folder for the current user. |
![]() | IsLateAddinLoading | Indicates whether this add-in is loaded on the fly or not. If it is loaded when is Revit starting up, it is false, otherwise it should be true. |
![]() | Language | The language used in the current session of Revit. |
![]() | Product | The product type for the current session of Revit. |
![]() | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to. |
![]() | SharedParametersFilename | Contains the fully qualified path to a shared parameters file. |
![]() | SubVersionNumber | The minor version number of Revit |
![]() | VersionBuild | Returns the internal build number of the Autodesk Revit application. |
![]() | VersionName | Returns the name of the Revit application. |
![]() | VersionNumber | Return the primary version of the Revit application. |

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() ![]() | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() ![]() | GetLibraryPaths | Returns path information identifying where Revit searches for content. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsJournalPlaying | Determines if the application is currently in journal playback mode. |
![]() | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk. |
![]() ![]() | RegisterFailuresProcessor | Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface. |
![]() | SetLibraryPaths | Sets path information identifying where Revit searches for content. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |
![]() | WriteJournalComment | Writes a comment to the Revit journal file. |

Name | Description | |
---|---|---|
![]() | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized |
![]() | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed. |
![]() | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document. |
![]() | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document. |
![]() | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document. |
![]() | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document. |
![]() ![]() | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document. |
![]() | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document. |
![]() ![]() | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document. |
![]() ![]() | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document. |
![]() | DocumentReloadedLatest | Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model. |
![]() | DocumentReloadingLatest | Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model. |
![]() | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document. |
![]() | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name. |
![]() | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document. |
![]() ![]() | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name. |
![]() | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model. |
![]() | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model. |
![]() | ElementTypeDuplicated | Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type. |
![]() | ElementTypeDuplicating | Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type. |
![]() ![]() | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction. |
![]() | FamilyLoadedIntoDocument | Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document. |
![]() | FamilyLoadingIntoDocument | Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document. |
![]() | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API. |
![]() | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API. |
![]() | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API. |
![]() | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API. |
![]() | LinkedResourceOpened | Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource. |
![]() | LinkedResourceOpening | Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource. |
![]() | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available. |
![]() ![]() | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document. |
![]() ![]() | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document. |
![]() | WorksharedOperationProgressChanged | Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central. |