Contains Method


Reference Contains Method

Checks if given reference identifies part of object identified by this reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Contains(
	Reference reference
)

Parameters

reference Reference
Another reference.

Return Value

Boolean
Returns true if given reference identifies part of object identified by this reference, false otherwise.
Exceptions
Exception Condition
ArgumentNullException Thrown when argument is .
Remarks
Can be used to check:
  • If given Reference is a part of a particular Subelement identified by this Reference.
  • If given Reference is a part of a particular Element identified by this Reference.
The input reference can refer to a subelement or a specific geometric item from an element or subelement.
See Also