IsValidTypeId Method


Direct Shape Is Valid Type Id Method

Tests the type id to make sure it satisfies the following conditions
  • It is a valid element id.
  • It corresponds to a valid DirectShapeType.
  • The DirectShapeType has the same category assigned.
Additionally, this functions tests that the current type id in this DirectShape is invalid. The type id is initialized to invalidElementId by the create functions. Once it is set, it may no longer be changed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidTypeId(
	ElementId typeId
)

Parameters

typeId ElementId
Type id to be tested.

Return Value

Boolean
False unless typeId satisfies the conditions listed above and the type id of this object was not set previously.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also