Direct |
Tests the type id to make sure it satisfies the following conditions
- It is a valid element id.
- It corresponds to a valid DirectShapeType.
- The DirectShapeType has the same category assigned.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- typeId ElementId
- Type id to be tested.
Return Value
BooleanFalse unless typeId satisfies the conditions listed above and the type id of this object was not set previously.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |