Light |
This class is the base class for specifying light distribution.

System Object
Autodesk.Revit.DB.Lighting LightDistribution
Autodesk.Revit.DB.Lighting HemisphericalLightDistribution
Autodesk.Revit.DB.Lighting PhotometricWebLightDistribution
Autodesk.Revit.DB.Lighting SphericalLightDistribution
Autodesk.Revit.DB.Lighting SpotLightDistribution
Autodesk.Revit.DB.Lighting LightDistribution
Autodesk.Revit.DB.Lighting HemisphericalLightDistribution
Autodesk.Revit.DB.Lighting PhotometricWebLightDistribution
Autodesk.Revit.DB.Lighting SphericalLightDistribution
Autodesk.Revit.DB.Lighting SpotLightDistribution
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The LightDistribution type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Clone | Creates a copy of the LightDistribution derived object. |
![]() | Dispose | Releases all resources used by the LightDistribution |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |