LightDistribution Class


Light Distribution Class

This class is the base class for specifying light distribution.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LightDistribution : IDisposable

The LightDistribution type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Clone Creates a copy of the LightDistribution derived object.
Public method Dispose Releases all resources used by the LightDistribution
Top
See Also