Label |
Used to obtain user-visible names for enums.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The LabelUtils type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the LabelUtils |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() ![]() | GetLabelFor(BuiltInCategory) | Gets the user-visible name for a BuiltInCategory. |
![]() ![]() | GetLabelFor(BuiltInParameter) | Gets the user-visible name for a BuiltInParameter. |
![]() ![]() | GetLabelFor(BuiltInParameter, LanguageType) | Gets the user-visible name for a BuiltInParameter in a specific LanguageType. |
![]() ![]() | GetLabelFor(DuctLossMethodType, Document) | Gets the user-visible name for a DuctLossMethodType. |
![]() ![]() | GetLabelFor(gbXMLBuildingType, Document) | Gets the user-visible name for a gbXMLBuildingType. |
![]() ![]() | GetLabelFor(PipeFlowState, Document) | Gets the user-visible name for a PipeFlowState. |
![]() ![]() | GetLabelFor(PipeLossMethodType, Document) | Gets the user-visible name for a PipeLossMethodType. |
![]() ![]() | GetLabelForBuiltInParameter(ForgeTypeId) | Gets the user-visible name for a built-in parameter. |
![]() ![]() | GetLabelForBuiltInParameter(ForgeTypeId, LanguageType) | Gets the user-visible name for a built-in parameter in a specific LanguageType. |
![]() ![]() | GetLabelForDiscipline | Gets the user-visible name for a discipline. |
![]() ![]() | GetLabelForGroup | Gets the user-visible name for a built-in parameter group. To get the name of parameter group "Other", pass an empty, default-constructed ForgeTypeId. |
![]() ![]() | GetLabelForSpec | Gets the user-visible name for a spec. |
![]() ![]() | GetLabelForSymbol | Gets the user-visible name for a symbol. |
![]() ![]() | GetLabelForUnit | Gets the user-visible name for a unit. |
![]() ![]() | GetStructuralSectionShapeName | Gets the user-visible name for a StructuralSectionShape. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |