LabelUtils Class


Label Utils Class

Used to obtain user-visible names for enums.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB LabelUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LabelUtils : IDisposable

The LabelUtils type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the LabelUtils
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method Static member GetLabelFor(BuiltInCategory) Gets the user-visible name for a BuiltInCategory.
Public method Static member GetLabelFor(BuiltInParameter) Gets the user-visible name for a BuiltInParameter.
Public method Static member GetLabelFor(BuiltInParameter, LanguageType) Gets the user-visible name for a BuiltInParameter in a specific LanguageType.
Public method Static member GetLabelFor(DuctLossMethodType, Document) Gets the user-visible name for a DuctLossMethodType.
Public method Static member GetLabelFor(gbXMLBuildingType, Document) Gets the user-visible name for a gbXMLBuildingType.
Public method Static member GetLabelFor(PipeFlowState, Document) Gets the user-visible name for a PipeFlowState.
Public method Static member GetLabelFor(PipeLossMethodType, Document) Gets the user-visible name for a PipeLossMethodType.
Public method Static member GetLabelForBuiltInParameter(ForgeTypeId) Gets the user-visible name for a built-in parameter.
Public method Static member GetLabelForBuiltInParameter(ForgeTypeId, LanguageType) Gets the user-visible name for a built-in parameter in a specific LanguageType.
Public method Static member GetLabelForDiscipline Gets the user-visible name for a discipline.
Public method Static member GetLabelForGroup Gets the user-visible name for a built-in parameter group. To get the name of parameter group "Other", pass an empty, default-constructed ForgeTypeId.
Public method Static member GetLabelForSpec Gets the user-visible name for a spec.
Public method Static member GetLabelForSymbol Gets the user-visible name for a symbol.
Public method Static member GetLabelForUnit Gets the user-visible name for a unit.
Public method Static member GetStructuralSectionShapeName Gets the user-visible name for a StructuralSectionShape.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also