ViewDisplayDepthCueing Class


View Display Depth Cueing Class

Represents the settings for depth cueing.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ViewDisplayDepthCueing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ViewDisplayDepthCueing : IDisposable

The ViewDisplayDepthCueing type exposes the following members.

Properties
Name Description
Public property EnableDepthCueing True to enable depth cueing. False to disable it.
Public property EndPercentage The end percentage defines where depth cueing ends. Values between 0 and 100.
Public property FadeTo The fade to defines the maximum fading in per cent. Values between 0 and 100.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property StartPercentage The start percentage defines where depth cueing starts. Values between 0 and 100.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ViewDisplayDepthCueing
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetStartEndPercentages Sets start and end percentages.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also