View |
Represents the settings for depth cueing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ViewDisplayDepthCueing type exposes the following members.

Name | Description | |
---|---|---|
![]() | EnableDepthCueing | True to enable depth cueing. False to disable it. |
![]() | EndPercentage | The end percentage defines where depth cueing ends. Values between 0 and 100. |
![]() | FadeTo | The fade to defines the maximum fading in per cent. Values between 0 and 100. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | StartPercentage | The start percentage defines where depth cueing starts. Values between 0 and 100. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ViewDisplayDepthCueing |
![]() | SetStartEndPercentages | Sets start and end percentages. |

private void AdjustDepthCueing(View view)
{
if (view.CanUseDepthCueing())
{
using (Transaction t = new Transaction(view.Document, "Change depth cueing"))
{
t.Start();
ViewDisplayDepthCueing depthCueing = view.GetDepthCueing();
depthCueing.EnableDepthCueing = true;
depthCueing.FadeTo = 50; // set fade to percent
depthCueing.SetStartEndPercentages(0, 75);
view.SetDepthCueing(depthCueing);
t.Commit();
}
}
}