GetSubelement Method (Reference)


Document Get Subelement(Reference) Method

Gets the subelement referenced by the input reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Subelement GetSubelement(
	Reference reference
)

Parameters

reference Reference
The reference that identifies element or subelement.

Return Value

Subelement
The subelement referenced by the input argument.
Exceptions
Exception Condition
ArgumentException reference does not identify a valid element or subelement.
ArgumentNullException A non-optional argument was null
See Also