IFCFileReadOptions Class


IFCFile Read Options Class

This class contains options to read an IFC file.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC IFCFileReadOptions

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCFileReadOptions : IDisposable

The IFCFileReadOptions type exposes the following members.

Constructors
Name Description
Public method IFCFileReadOptions Creates a default IFCFileReadOptions.
Top
Properties
Name Description
Public property FileName The full file name of the IFC file to be read.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property XMLConfigFileName The XML configuration file name. It is used only for reading IFC-XML format file.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the IFCFileReadOptions
Top
See Also