Numeric |
Contains settings that apply to Revisions with the Numeric RevisionNumberType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The NumericRevisionSettings type exposes the following members.

Name | Description | |
---|---|---|
![]() | NumericRevisionSettings | Constructs a NumericRevisionSettings with a simple, default numbering sequence. |
![]() | NumericRevisionSettings(NumericRevisionSettings) | Constructs a new copy of the input NumericRevisionSettings object. |
![]() | NumericRevisionSettings(Int32, String, String) | Constructs a NumericRevisionSettings object. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | MinimumDigits | Controls the minimum number of digits for a revision number. |
![]() | Prefix | The prefix string that will be prepended to the number of each revision with Numeric RevisionNumberingType. |
![]() | StartNumber | The start number for the sequence. |
![]() | Suffix | The suffix string that will be appended to the number of each revision with Numeric RevisionNumberingType. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the NumericRevisionSettings |
![]() | IsEqual | Determines whether a specified NumericRevisionSettings is the same as 'this'. |
![]() | IsValid | Determines whether the NumericRevisionSettings object is in a valid state. |