NumericRevisionSettings Class


Numeric Revision Settings Class

Contains settings that apply to Revisions with the Numeric RevisionNumberType.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB NumericRevisionSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class NumericRevisionSettings : IDisposable

The NumericRevisionSettings type exposes the following members.

Constructors
Name Description
Public method NumericRevisionSettings Constructs a NumericRevisionSettings with a simple, default numbering sequence.
Public method NumericRevisionSettings(NumericRevisionSettings) Constructs a new copy of the input NumericRevisionSettings object.
Public method NumericRevisionSettings(Int32, String, String) Constructs a NumericRevisionSettings object.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MinimumDigits Controls the minimum number of digits for a revision number.
Public property Prefix The prefix string that will be prepended to the number of each revision with Numeric RevisionNumberingType.
Public property StartNumber The start number for the sequence.
Public property Suffix The suffix string that will be appended to the number of each revision with Numeric RevisionNumberingType.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the NumericRevisionSettings
Public method IsEqual Determines whether a specified NumericRevisionSettings is the same as 'this'.
Public method IsValid Determines whether the NumericRevisionSettings object is in a valid state.
Top
See Also