PointCollection Class


Point Collection Class

A class that represents a set of points created and returned by Revit in response to a query.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.PointClouds PointCollection

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointCollection : IEnumerable<CloudPoint>, 
	IDisposable

The PointCollection type exposes the following members.

Properties
Name Description
Public property Count The number of points in this collection.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the PointCollection
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetPointBufferPointer Returns an unsafe pointer to the buffer in which this collection stores the points.
Public method GetPointIterator Creates and returns an iterator for the points contained in this collection.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also