Ceramic Class


Ceramic Class

A static class that provides access to the property names that appear in the Ceramic visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual Ceramic

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Ceramic

The Ceramic type exposes the following members.

Properties
Name Description
Public property Static member CeramicApplication The property labeled "Finish" from the "Ceramic" schema.
Public property Static member CeramicBump The property labeled "Type" from the "Ceramic" schema.
Public property Static member CeramicBumpAmount The property labeled "Amount" from the "Ceramic" schema.
Public property Static member CeramicBumpMap The property labeled "Image" from the "Ceramic" schema.
Public property Static member CeramicColor The property labeled "Color" from the "Ceramic" schema.
Public property Static member CeramicColorByObject The property labeled "Color" from the "Ceramic" schema.
Public property Static member CeramicPattern The property labeled "Relief Pattern" from the "Ceramic" schema.
Public property Static member CeramicPatternAmount The property labeled "Amount" from the "Ceramic" schema.
Public property Static member CeramicPatternMap The property labeled "Image" from the "Ceramic" schema.
Public property Static member CeramicType The property labeled "Type" from the "Ceramic" schema.
Public property Static member CommonTintColor The property labeled "Tint Color" from the "Ceramic" schema.
Public property Static member CommonTintToggle The property labeled "Tint" from the "Ceramic" schema.
Top
See Also