Line |
Sets start and end point of the line load.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentException | Thrown when the end point is equal to the start point. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This LineLoad is not a hosted load. -or- This LineLoad is a constrained load. |

This method works with hosted line load only. This method works for loads which are not constrained to their host. The curve of the resulted load will be a line.