SetPoints Method


Line Load Set Points Method

Sets start and end point of the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool SetPoints(
	XYZ startPoint,
	XYZ endPoint
)

Parameters

startPoint XYZ
The start point.
endPoint XYZ
The end point.

Return Value

Boolean
Returns true if successful, false otherwise.
Exceptions
Exception Condition
ArgumentException Thrown when the end point is equal to the start point.
ArgumentNullException A non-optional argument was null
InvalidOperationException This LineLoad is not a hosted load. -or- This LineLoad is a constrained load.
Remarks
This method works with hosted line load only. This method works for loads which are not constrained to their host. The curve of the resulted load will be a line.
See Also