GetLightType Method


Light Family Get Light Type Method

Return a LightType object for the light type at the given index

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public LightType GetLightType(
	int index
)

Parameters

index Int32
The index of the light type

Return Value

LightType
A LightType object for the light type at the given index
Exceptions
Exception Condition
ArgumentException The index is the argument that is being validated The index is not valid because it does not correspond to a valid light type
See Also