Element |
A render node that represents an element, including the host document containing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The ElementNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | Document | Gets the document associated with the element. |
![]() | ElementId | The Id of the element. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode ) |
![]() | LinkInstanceId | The Id of the link instance for the element. |
![]() | NodeName | A readable name of the output node. (Inherited from RenderNode ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RenderNode ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

See also: [!:Autodesk::Revit::DB::IExportContext2D::OnElementBegin2D] . See also: [!:Autodesk::Revit::DB::IExportContext2D::OnElementEnd2D] .