ElementNode Class


Element Node Class

A render node that represents an element, including the host document containing the element.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementNode : RenderNode

The ElementNode type exposes the following members.

Properties
Name Description
Public property Document Gets the document associated with the element.
Public property ElementId The Id of the element.
Public property LinkInstanceId The Id of the link instance for the element.
Top
Methods
Name Description
Top
Remarks
See Also