ElementNode Class


Element Node Class

A render node that represents an element, including the host document containing the element.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementNode : RenderNode

The ElementNode type exposes the following members.

Properties
Name Description
Public property Document Gets the document associated with the element.
Public property ElementId The Id of the element.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode )
Public property LinkInstanceId The Id of the link instance for the element.
Public property NodeName A readable name of the output node.
(Inherited from RenderNode )
Top
Methods
Name Description
Public method Dispose
(Inherited from RenderNode )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
See Also