NewDimension Method (View, Line, ReferenceArray)


Item Factory Base New Dimension(View, Line, Reference Array) Method

Creates a new linear dimension object using the default dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Dimension NewDimension(
	View view,
	Line line,
	ReferenceArray references
)

Parameters

view View
The view in which the dimension is to be visible. The view must be if the document is in [!:Autodesk::Revit::DB::SketchEditScope] .
line Line
The line drawn for the dimension.
references ReferenceArray
An array of geometric references to which the dimension is to be bound.

Return Value

Dimension
If successful a new dimension object, otherwise .
Exceptions
Exception Condition
ArgumentException Thrown when references are not geometric references.
Remarks
The currently user set default style is used for the created dimension.
See Also