Item |
Creates a new linear dimension object using the default dimension style.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- view View
- The view in which the dimension is to be visible. The view must be if the document is in [!:Autodesk::Revit::DB::SketchEditScope] .
- line Line
- The line drawn for the dimension.
- references ReferenceArray
- An array of geometric references to which the dimension is to be bound.
Return Value
DimensionIf successful a new dimension object, otherwise .

Exception | Condition |
---|---|
ArgumentException | Thrown when references are not geometric references. |

The currently user set default style is used for the created dimension.

Dimension CreateNewDimensionAlongLine(Autodesk.Revit.DB.Document document, Line line)
{
// Use the Start and End points of our line as the references
// Line must come from something in Revit, such as a beam
ReferenceArray references = new ReferenceArray();
references.Append(line.GetEndPointReference(0));
references.Append(line.GetEndPointReference(1));
// create the new dimension
Dimension dimension = document.Create.NewDimension(document.ActiveView,
line, references);
return dimension;
}