Transformed Property


Profile Transformed Property

Transforms this profile and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Profile this[
	Transform transform
] { get; }

Parameters

transform Transform
The transformation used to transform the profile.

Return Value

Profile
The transformed profile.
Exceptions
Exception Condition
ArgumentNullException Thrown when the handle of the specified transformation is .
InvalidOperationException Thrown when failed to transform a curve in the profile.
Remarks
Transforms all the curves that define the boundary of this profile.
See Also