Profile Transformed Property |
Transforms this profile and returns the result.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- transform Transform
- The transformation used to transform the profile.
Return Value
ProfileThe transformed profile.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the handle of the specified transformation is . |
InvalidOperationException | Thrown when failed to transform a curve in the profile. |

Transforms all the curves that define the boundary of this profile.