Create Method (Document, Element, IList(CurveLoop), XYZ, XYZ, ElementId, ElementId)


Fabric Area Create(Document, Element, IList Curve Loop , XYZ, XYZ, Element Id, Element Id) Method


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static FabricArea Create(
	Document aDoc,
	Element hostElement,
	IList<CurveLoop> curveLoops,
	XYZ majorDirection,
	XYZ majorDirectionOrigin,
	ElementId fabricAreaTypeId,
	ElementId fabricSheetTypeId
)

Parameters

aDoc Document
hostElement Element
curveLoops IList CurveLoop
majorDirection XYZ
majorDirectionOrigin XYZ
fabricAreaTypeId ElementId
fabricSheetTypeId ElementId

Return Value

FabricArea
See Also