Create Method (Document, Element, IList(CurveLoop), XYZ, XYZ, ElementId, ElementId)


Fabric Area Create(Document, Element, IList Curve Loop , XYZ, XYZ, Element Id, Element Id) Method

Creates a FabricArea from an array of curves.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FabricArea Create(
	Document aDoc,
	Element hostElement,
	IList<CurveLoop> curveLoops,
	XYZ majorDirection,
	XYZ majorDirectionOrigin,
	ElementId fabricAreaTypeId,
	ElementId fabricSheetTypeId
)

Parameters

aDoc Document
The document.
hostElement Element
The element that will host the FabricArea. The host can be a Structural Floor, Structural Wall, Structural Slab, or a Part created from a structural layer belonging to one of those element types.
curveLoops IList CurveLoop
An array of curves that will define the outline of the FabricArea. This includes curves defining openings in the interior of the area.
majorDirection XYZ
A vector to define the major direction of the FabricArea.
majorDirectionOrigin XYZ
An origin point of the major direction line
fabricAreaTypeId ElementId
The id of the FabricAreaType.
fabricSheetTypeId ElementId
The id of the FabricSheetType.

Return Value

FabricArea
The newly created FabricArea.
Exceptions
Exception Condition
ArgumentException Not all curveLoops in curveLoops are closed and continuous. -or- Not all curveLoops in curveLoops are in the same plane. -or- curveLoops should only contain lines or arcs. -or- The element hostElement was not found in the given document. -or- the host Element is not a valid host for Area Reinforcement, Path Reinforcement, Fabric Area or Fabric Sheet. -or- fabricAreaTypeId should refer to an FabricAreaType element. -or- fabricSheetTypeId should refer to an FabricSheetType element.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException majorDirection has zero length.
See Also