FilePath Class


File Path Class

This class represents a path on a disk or network location, but not a path to a Revit server location.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilePath : ModelPath

The FilePath type exposes the following members.

Constructors
Name Description
Public method FilePath Constructs a FilePath
Top
Properties
Name Description
Public property CentralServerPath The path to the location of the central Revit server or cloud.
(Inherited from ModelPath )
Public property CloudPath Whether this path represents a path on an Autodesk server such as BIM360.
(Inherited from ModelPath )
Public property Empty Whether this path is empty
(Inherited from ModelPath )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ModelPath )
Public property Region The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model.
(Inherited from ModelPath )
Public property ServerPath Whether this path is a server path (as opposed to a file path or cloud path)
(Inherited from ModelPath )
Top
Methods
Name Description
Public method Compare Compares this ModelPath with another
(Inherited from ModelPath )
Public method Dispose
(Inherited from ModelPath )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetModelGUID A GUID identifying the Revit cloud model.
(Inherited from ModelPath )
Public method GetProjectGUID A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated.
(Inherited from ModelPath )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also