InSessionPrintSetting Class


In Session Print Setting Class

Represents the in-session Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB InSessionPrintSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class InSessionPrintSetting : IPrintSetting, 
	IDisposable

The InSessionPrintSetting type exposes the following members.

Properties
Name Description
Public property PrintParameters Returns the Parameters of Print Setup.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the InSessionPrintSetting
Top
Remarks
The in-session PrintSetting can't be stored in document.
See Also