WinderPathResult Enumeration


Winder Path Result Enumeration

Flag indicates whether curves are valid to use as base lines for winder path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum WinderPathResult
Members
Member name Value Description
ColinearOrOverlap 6 Two curves are collinear or overlap.
InvalidCurveType 8 Curve is not line.
Noncontinuous 3 The curves are not continuous in one loop.
NotOpenLoop 4 The curves are not in one open loop.
NotSupported 9 This path(for zigzag winder) is not supported yet
NumberOutOfRange 1 The curves number is not 2 or 3.
SelfIntersect 7 The first curve intersect with third curve.
Success 0 Indicates curves are valid to use as path base lines for winder run. This is only one flag indicates curves are fine to use as winder path.
TooShort 5 Curve length is too short.
Unbound 2 Curve is not bound.
See Also