AppendItemFromCurvesAndShape Method


Rebar Container Append Item From Curves And Shape Method


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public RebarContainerItem AppendItemFromCurvesAndShape(
	RebarShape rebarShape,
	RebarBarType barType,
	RebarHookType startHook,
	RebarHookType endHook,
	XYZ normal,
	IList<Curve> curves,
	RebarHookOrientation startHookOrient,
	RebarHookOrientation endHookOrient
)

Parameters

rebarShape RebarShape
barType RebarBarType
startHook RebarHookType
endHook RebarHookType
normal XYZ
curves IList Curve
startHookOrient RebarHookOrientation
endHookOrient RebarHookOrientation

Return Value

RebarContainerItem
See Also