AppendItemFromCurvesAndShape Method


Rebar Container Append Item From Curves And Shape(Rebar Shape, Rebar Bar Type, Rebar Hook Type, Rebar Hook Type, XYZ, IList Curve , Rebar Hook Orientation, Rebar Hook Orientation) Method

Note: This API is now obsolete.


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarContainer.AppendItemFromCurvesAndShape(RebarShape rebarShape, RebarBarType barType, RebarHookType startHook, RebarHookType endHook, XYZ normal, IList<Curve> curves, RebarTerminationOrientation startHookOrient, RebarTerminationOrientation endHookOrient) instead.")]
public RebarContainerItem AppendItemFromCurvesAndShape(
	RebarShape rebarShape,
	RebarBarType barType,
	RebarHookType startHook,
	RebarHookType endHook,
	XYZ normal,
	IList<Curve> curves,
	RebarHookOrientation startHookOrient,
	RebarHookOrientation endHookOrient
)

Parameters

rebarShape RebarShape
barType RebarBarType
startHook RebarHookType
endHook RebarHookType
normal XYZ
curves IList Curve
startHookOrient RebarHookOrientation
endHookOrient RebarHookOrientation

Return Value

RebarContainerItem
See Also