WorksetPreview Class


Workset Preview Class

Represents an accessor for workset data which can be obtained from an unopened document.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB WorksetPreview
Autodesk.Revit.DB Workset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WorksetPreview : IDisposable

The WorksetPreview type exposes the following members.

Properties
Name Description
Public property Id Id of the workset.
Public property IsDefaultWorkset Whether the workset is the default one.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name Name of the workset.
Public property Owner User name of the workset.
Public property UniqueId UniqueId of the workset.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the WorksetPreview
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
As a base class of Workset, this class has limited access to data. WorksetPreviews are obtained from WorksharingUtils.GetUserWorksetInfo() from an unopened document.
See Also