Workset |
Represents an accessor for workset data which can be obtained from an unopened document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The WorksetPreview type exposes the following members.

Name | Description | |
---|---|---|
![]() | Id | Id of the workset. |
![]() | IsDefaultWorkset | Whether the workset is the default one. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Name | Name of the workset. |
![]() | Owner | User name of the workset. |
![]() | UniqueId | UniqueId of the workset. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the WorksetPreview |

As a base class of Workset, this class has limited access to data. WorksetPreviews are obtained from WorksharingUtils.GetUserWorksetInfo() from an unopened document.