ScaleProfile Method


Form Scale Profile Method

Scale a profile of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ScaleProfile(
	int profileIndex,
	double factor,
	XYZ origin
)

Parameters

profileIndex Int32
Index to specify the profile.
factor Double
The scale factor, it should be large than zero.
origin XYZ
The origin where scale happens.
See Also