Form Scale Profile Method Scale a profile of the form, by a specified origin and scale factor. Namespace: Autodesk.Revit.DB Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0) Syntax C# VB C++ F# public void ScaleProfile( int profileIndex, double factor, XYZ origin ) Public Sub ScaleProfile ( profileIndex As Integer, factor As Double, origin As XYZ ) public: void ScaleProfile( int profileIndex, double factor, XYZ^ origin ) member ScaleProfile : profileIndex : int * factor : float * origin : XYZ -> unit Parameters profileIndex Int32 Index to specify the profile. factor Double The scale factor, it should be large than zero. origin XYZ The origin where scale happens. See Also Reference Form Class Autodesk.Revit.DB Namespace
Form Scale Profile Method Scale a profile of the form, by a specified origin and scale factor. Namespace: Autodesk.Revit.DB Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0) Syntax C# VB C++ F# public void ScaleProfile( int profileIndex, double factor, XYZ origin ) Public Sub ScaleProfile ( profileIndex As Integer, factor As Double, origin As XYZ ) public: void ScaleProfile( int profileIndex, double factor, XYZ^ origin ) member ScaleProfile : profileIndex : int * factor : float * origin : XYZ -> unit Parameters profileIndex Int32 Index to specify the profile. factor Double The scale factor, it should be large than zero. origin XYZ The origin where scale happens. See Also Reference Form Class Autodesk.Revit.DB Namespace