DuctSizes Class


Duct Sizes Class

Class RbsDuctSizes being used to store the duct sizes
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Mechanical DuctSizes

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DuctSizes : IEnumerable<MEPSize>, 
	IDisposable

The DuctSizes type exposes the following members.

Properties
Name Description
Public property Count Count of the items contained in the collection.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Contains Checks whether a duct size with the nominal diameter exists.
Public method Dispose Releases all resources used by the DuctSizes
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetDuctSizeIterator Returns a DuctSizeIterator that iterates through the collection.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Top
See Also