SplitButton Class


Split Button Class

The SplitButton object represents a button with a clickable button appearing above a pulldown.
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SplitButton : PulldownButton

The SplitButton type exposes the following members.

Properties
Name Description
Public property CurrentButton Gets or sets the current PushButton of the SplitButton.
Public property Enabled Gets or sets a value indicating whether the item is enabled.
(Inherited from RibbonItem )
Public property Image The image of the button.
(Inherited from RibbonButton )
Public property IsEnabledByContext Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context.
(Inherited from RibbonButton )
Public property IsSynchronizedWithCurrentItem Indicates whether the top PushButton on the SplitButton changes based on the CurrentButton property.
Public property ItemText Gets or sets the text displayed on the item.
(Inherited from RibbonItem )
Public property ItemType Gets the item type.
(Inherited from RibbonItem )
Public property LargeImage The large image shown on the button.
(Inherited from RibbonButton )
Public property LongDescription Long description of the command tooltip
(Inherited from RibbonItem )
Public property Name The name of the item.
(Inherited from RibbonItem )
Public property ToolTip The description that appears as a ToolTip for the item.
(Inherited from RibbonItem )
Public property ToolTipImage The image to show as a part of the button extended tooltip
(Inherited from RibbonItem )
Public property Visible Gets or sets a value indicating whether the item is visible.
(Inherited from RibbonItem )
Top
Methods
Name Description
Public method AddPushButton Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.
(Inherited from PulldownButton )
Public method AddSeparator Adds a separator to the drop-down list.
(Inherited from PulldownButton )
Public method Equals Determines whether the specified Object is equal to the current Object .
(Inherited from RibbonItem )
Public method GetContextualHelp Gets the contextual help bound with this control.
(Inherited from RibbonItem )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetItems Gets a copy of the collection of buttons assigned to the pulldown button.
(Inherited from PulldownButton )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetContextualHelp Sets the contextual help bound with this button.
(Inherited from RibbonItem )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Use of this class is not supported in Revit Macros.
See Also