SplitButton Class


Split Button Class

The SplitButton object represents a button with a clickable button appearing above a pulldown.
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SplitButton : PulldownButton

The SplitButton type exposes the following members.

Properties
Name Description
Public property CurrentButton Gets or sets the current PushButton of the SplitButton.
Public property IsSynchronizedWithCurrentItem Indicates whether the top PushButton on the SplitButton changes based on the CurrentButton property.
Top
Methods
Name Description
Top
Remarks
Use of this class is not supported in Revit Macros.
See Also