Split |
The SplitButton object represents a button with a clickable button appearing above a pulldown.

System Object
Autodesk.Revit.UI RibbonItem
Autodesk.Revit.UI RibbonButton
Autodesk.Revit.UI PulldownButton
Autodesk.Revit.UI SplitButton
Autodesk.Revit.UI RibbonItem
Autodesk.Revit.UI RibbonButton
Autodesk.Revit.UI PulldownButton
Autodesk.Revit.UI SplitButton
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The SplitButton type exposes the following members.

Name | Description | |
---|---|---|
![]() | CurrentButton | Gets or sets the current PushButton of the SplitButton. |
![]() | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem ) |
![]() | Image | The image of the button. (Inherited from RibbonButton ) |
![]() | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context. (Inherited from RibbonButton ) |
![]() | IsSynchronizedWithCurrentItem | Indicates whether the top PushButton on the SplitButton changes based on the CurrentButton property. |
![]() | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem ) |
![]() | ItemType | Gets the item type. (Inherited from RibbonItem ) |
![]() | LargeImage | The large image shown on the button. (Inherited from RibbonButton ) |
![]() | LongDescription | Long description of the command tooltip (Inherited from RibbonItem ) |
![]() | Name | The name of the item. (Inherited from RibbonItem ) |
![]() | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem ) |
![]() | ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem ) |
![]() | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem ) |

Name | Description | |
---|---|---|
![]() | AddPushButton | Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand. (Inherited from PulldownButton ) |
![]() | AddSeparator | Adds a separator to the drop-down list. (Inherited from PulldownButton ) |
![]() | Equals | Determines whether the specified Object is equal to the current Object . (Inherited from RibbonItem ) |
![]() | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetItems | Gets a copy of the collection of buttons assigned to the pulldown button. (Inherited from PulldownButton ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Use of this class is not supported in Revit Macros.

private void AddSplitButton(RibbonPanel panel)
{
string assembly = @"D:\Sample\HelloWorld\bin\Debug\HelloWorld.dll";
// create push buttons for split button drop down
PushButtonData bOne = new PushButtonData("ButtonNameA", "Option One",
assembly, "Hello.HelloOne");
bOne.LargeImage =
new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\One.bmp"));
PushButtonData bTwo = new PushButtonData("ButtonNameB", "Option Two",
assembly, "Hello.HelloTwo");
bTwo.LargeImage =
new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Two.bmp"));
PushButtonData bThree = new PushButtonData("ButtonNameC", "Option Three",
assembly, "Hello.HelloThree");
bThree.LargeImage =
new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Three.bmp"));
SplitButtonData sb1 = new SplitButtonData("splitButton1", "Split");
SplitButton sb = panel.AddItem(sb1) as SplitButton;
sb.AddPushButton(bOne);
sb.AddPushButton(bTwo);
sb.AddPushButton(bThree);
}