KeyBasedTreeEntries Class


Key Based Tree Entries Class

A collection of KeyBasedTreeEntry objects that make up the key-based tree.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class KeyBasedTreeEntries : IEnumerable<KeyBasedTreeEntry>, 
	IDisposable

The KeyBasedTreeEntries type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the KeyBasedTreeEntries
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method FindEntry Finds the KeyBasedTreeEntry associated with the given key value.
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetKeyBasedTreeEntriesIterator Returns a KeyBasedTreeEntriesIterator that iterates through the collection.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also