Key |
A collection of KeyBasedTreeEntry objects that make up the key-based tree.

System Object
Autodesk.Revit.DB KeyBasedTreeEntries
Autodesk.Revit.DB ClassificationEntries
Autodesk.Revit.DB KeynoteEntries
Autodesk.Revit.DB KeyBasedTreeEntries
Autodesk.Revit.DB ClassificationEntries
Autodesk.Revit.DB KeynoteEntries
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The KeyBasedTreeEntries type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the KeyBasedTreeEntries |
![]() | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value. |
![]() | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. |
![]() | GetEnumerator | Returns an enumerator that iterates through a collection. |
![]() | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection. |