GetRodStructureExtension Method


Fabrication Rod Info Get Rod Structure Extension Method

Gets the length of the rod's top extension into structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double GetRodStructureExtension(
	int rodIndex
)

Parameters

rodIndex Int32
The rod index.

Return Value

Double
Returns the extension length that will be applied if the rod is attached to structure.
Exceptions
Exception Condition
ArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
See Also