Part |
Checks if an element has associated parts.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool HasAssociatedParts(
Document hostDocument,
LinkElementId hostOrLinkElementId
)
Parameters
- hostDocument Document
- The document.
- hostOrLinkElementId LinkElementId
- The element to be checked for associated Parts.
Return Value
BooleanTrue if the element has associated Parts.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |