Export |
Represents the mapped IFC information stored in the template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ExportIFCCategoryInfo type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExportIFCCategoryInfo | Constructs a new ExportIFCCategoryInfo with default values. |
![]() | ExportIFCCategoryInfo(Boolean, String, String, String, String) | Constructs a new ExportIFCCategoryInfo with input values. |

Name | Description | |
---|---|---|
![]() | IFCEntityName | The name of the IFC entity mapped to a particular Revit category. |
![]() | IFCExportFlag | The boolean value that indicates whether the category is exported to ifc. |
![]() | IFCPredefinedType | The name of the predefined type mapped to a particular Revit category. |
![]() | IFCPresentationLayerName | The name of the presentation layer mapped to a particular Revit category. |
![]() | IFCUserDefinedType | The name of the user-defined type mapped to a particular Revit category. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ExportIFCCategoryInfo |
![]() | IsDefault | Determines if a ExportIFCCategoryInfo contains default information. |